llvm.org GIT mirror llvm / 9230ff9
[lit] Make the 'llvm-lit' utility defend against a system where Python3 is the default. The lit.cfg files are not all valid Python3 and I've no idea if anyone is really prepared to update them. The easiest way I know of to ensure that this script uses Python 2 is to use 'python2.7' in the command. Mac and Linux are definitely fine with this and I think other platforms will be as well, but if anyone struggles with this set up and has better ideas, let me know. git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@229244 91177308-0d34-0410-b5e6-96231b3b80d8 Chandler Carruth 4 years ago
1 changed file(s) with 1 addition(s) and 1 deletion(s). Raw diff Collapse all Expand all
None #!/usr/bin/env python
0 #!/usr/bin/env python2.7
11
22 import os
33 import sys