llvm.org GIT mirror llvm / 708bc15
Require python 2.7. We were already requiring 2.5, which meant that people on old linux distros had to upgrade anyway. Requiring python 2.6 will make supporting 3.X easier as we can use the 3.X exception syntax. According to the discussion on llvmdev, there is not much value is requiring just 2.6, we may as well just require 2.7. git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@224129 91177308-0d34-0410-b5e6-96231b3b80d8 Rafael Espindola 4 years ago
6 changed file(s) with 20 addition(s) and 22 deletion(s). Raw diff Collapse all Expand all
14201420 AC_MSG_WARN([specified python ($PYTHON) is not usable, searching path])
14211421 fi
14221422
1423 AC_PATH_PROG([PYTHON], [python python2 python26],
1423 AC_PATH_PROG([PYTHON], [python python2 python27],
14241424 [AC_MSG_RESULT([not found])
1425 AC_MSG_ERROR([could not find python 2.5 or higher])])
1426 fi
1427
1428 AC_MSG_CHECKING([for python >= 2.5])
1425 AC_MSG_ERROR([could not find python 2.7 or higher])])
1426 fi
1427
1428 AC_MSG_CHECKING([for python >= 2.7])
14291429 ac_python_version=`$PYTHON -V 2>&1 | cut -d' ' -f2`
14301430 ac_python_version_major=`echo $ac_python_version | cut -d'.' -f1`
14311431 ac_python_version_minor=`echo $ac_python_version | cut -d'.' -f2`
14321432 ac_python_version_patch=`echo $ac_python_version | cut -d'.' -f3`
14331433 if test "$ac_python_version_major" -gt "2" || \
14341434 (test "$ac_python_version_major" -eq "2" && \
1435 test "$ac_python_version_minor" -ge "5") ; then
1435 test "$ac_python_version_minor" -ge "7") ; then
14361436 AC_MSG_RESULT([$PYTHON ($ac_python_version)])
14371437 else
14381438 AC_MSG_RESULT([not found])
1439 AC_MSG_FAILURE([found python $ac_python_version ($PYTHON); required >= 2.5])
1439 AC_MSG_FAILURE([found python $ac_python_version ($PYTHON); required >= 2.7])
14401440 fi
14411441
14421442 dnl===-----------------------------------------------------------------------===
81588158 echo "$as_me: WARNING: specified python ($PYTHON) is not usable, searching path" >&2;}
81598159 fi
81608160
8161 # Extract the first word of "python python2 python26", so it can be a program name with args.
8162 set dummy python python2 python26; ac_word=$2
8161 # Extract the first word of "python python2 python27", so it can be a program name with args.
8162 set dummy python python2 python27; ac_word=$2
81638163 { echo "$as_me:$LINENO: checking for $ac_word" >&5
81648164 echo $ECHO_N "checking for $ac_word... $ECHO_C" >&6; }
81658165 if test "${ac_cv_path_PYTHON+set}" = set; then
81878187
81888188 test -z "$ac_cv_path_PYTHON" && ac_cv_path_PYTHON="{ echo "$as_me:$LINENO: result: not found" >&5
81898189 echo "${ECHO_T}not found" >&6; }
8190 { { echo "$as_me:$LINENO: error: could not find python 2.5 or higher" >&5
8191 echo "$as_me: error: could not find python 2.5 or higher" >&2;}
8190 { { echo "$as_me:$LINENO: error: could not find python 2.7 or higher" >&5
8191 echo "$as_me: error: could not find python 2.7 or higher" >&2;}
81928192 { (exit 1); exit 1; }; }"
81938193 ;;
81948194 esac
82058205
82068206 fi
82078207
8208 { echo "$as_me:$LINENO: checking for python >= 2.5" >&5
8209 echo $ECHO_N "checking for python >= 2.5... $ECHO_C" >&6; }
8208 { echo "$as_me:$LINENO: checking for python >= 2.7" >&5
8209 echo $ECHO_N "checking for python >= 2.7... $ECHO_C" >&6; }
82108210 ac_python_version=`$PYTHON -V 2>&1 | cut -d' ' -f2`
82118211 ac_python_version_major=`echo $ac_python_version | cut -d'.' -f1`
82128212 ac_python_version_minor=`echo $ac_python_version | cut -d'.' -f2`
82138213 ac_python_version_patch=`echo $ac_python_version | cut -d'.' -f3`
82148214 if test "$ac_python_version_major" -gt "2" || \
82158215 (test "$ac_python_version_major" -eq "2" && \
8216 test "$ac_python_version_minor" -ge "5") ; then
8216 test "$ac_python_version_minor" -ge "7") ; then
82178217 { echo "$as_me:$LINENO: result: $PYTHON ($ac_python_version)" >&5
82188218 echo "${ECHO_T}$PYTHON ($ac_python_version)" >&6; }
82198219 else
82208220 { echo "$as_me:$LINENO: result: not found" >&5
82218221 echo "${ECHO_T}not found" >&6; }
8222 { { echo "$as_me:$LINENO: error: found python $ac_python_version ($PYTHON); required >= 2.5
8222 { { echo "$as_me:$LINENO: error: found python $ac_python_version ($PYTHON); required >= 2.7
82238223 See \`config.log' for more details." >&5
8224 echo "$as_me: error: found python $ac_python_version ($PYTHON); required >= 2.5
8224 echo "$as_me: error: found python $ac_python_version ($PYTHON); required >= 2.7
82258225 See \`config.log' for more details." >&2;}
82268226 { (exit 1); exit 1; }; }
82278227 fi
163163 =========================================================== ============ ==========================================
164164 `GNU Make `_ 3.79, 3.79.1 Makefile/build processor
165165 `GCC `_ >=4.7.0 C/C++ compiler\ :sup:`1`
166 `python `_ >=2.5 Automated test suite\ :sup:`2`
166 `python `_ >=2.7 Automated test suite\ :sup:`2`
167167 `GNU M4 `_ 1.4 Macro processor for configuration\ :sup:`3`
168168 `GNU Autoconf `_ 2.60 Configuration script builder\ :sup:`3`
169169 `GNU Automake `_ 1.9.6 aclocal macro generator\ :sup:`3`
5656 generates the project files you will use to build with.
5757
5858 If you would like to run the LLVM tests you will need `Python
59 `_. Versions 2.4-2.7 are known to work. You will need
60 `GnuWin32 `_ tools, too.
59 `_. Version 2.7 and newer are known to work. You will
60 need `GnuWin32 `_ tools, too.
6161
6262 Do not install the LLVM directory tree into a path containing spaces (e.g.
6363 ``C:\Documents and Settings\...``) as the configure step will fail.
2121 ============
2222
2323 In order to use the LLVM testing infrastructure, you will need all of the
24 software required to build LLVM, as well as `Python `_ 2.5 or
24 software required to build LLVM, as well as `Python `_ 2.7 or
2525 later.
2626
2727 LLVM testing infrastructure organization
None # XFAIL: python2.5
1
2 # RUN: %{lit} -j 1 -v %{inputs}/test-data --output %t.results.out > %t.out
31 # RUN: FileCheck < %t.results.out %s
42