llvm.org GIT mirror llvm / 5826030
[asan] Make the global_metadata_darwin.ll test require El Capitan or newer git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@264758 91177308-0d34-0410-b5e6-96231b3b80d8 Ryan Govostes 4 years ago
2 changed file(s) with 13 addition(s) and 0 deletion(s). Raw diff Collapse all Expand all
11 ; allowing dead stripping to be performed, and that the appropriate runtime
22 ; routines are invoked.
33
4 ; REQUIRES: ld64_live_support
45 ; RUN: opt < %s -asan -asan-module -S | FileCheck %s
56
67 target datalayout = "e-m:o-i64:64-f80:128-n8:16:32:64-S128"
428428 if have_ld64_plugin_support():
429429 config.available_features.add('ld64_plugin')
430430
431
432 # Check if ld64 knows about live_support (OS X El Capital and newer).
433 if config.host_os == 'Darwin':
434 try:
435 osx_version = subprocess.check_output(["sw_vers", "-productVersion"])
436 osx_version = tuple(int(x) for x in osx_version.split('.'))
437 if osx_version >= (10, 11):
438 config.available_features.add('ld64_live_support')
439 except:
440 pass
441
442
431443 # Ask llvm-config about assertion mode.
432444 try:
433445 llvm_config_cmd = subprocess.Popen(