llvm.org GIT mirror llvm / 56d3491
Remove dead code, we already require cmake 2.8.8. git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@201495 91177308-0d34-0410-b5e6-96231b3b80d8 Rafael Espindola 5 years ago
2 changed file(s) with 1 addition(s) and 10 deletion(s). Raw diff Collapse all Expand all
3636 )
3737
3838 if( CMAKE_CL_64 )
39 # A workaround for a bug in cmake 2.8.3. See PR 8885.
40 if( CMAKE_VERSION STREQUAL "2.8.3" )
41 include(CMakeDetermineCompilerId)
42 endif()
43 # end of workaround.
4439 enable_language(ASM_MASM)
4540 ADD_CUSTOM_COMMAND(
4641 OUTPUT ${CMAKE_CURRENT_BINARY_DIR}/X86CompilationCallback_Win64.obj
1919 if(NOT MSVC)
2020 add_llvm_external_project(libcxx)
2121 endif()
22 if(${CMAKE_VERSION} VERSION_GREATER 2.8.7)
23 add_llvm_external_project(compiler-rt)
24 else()
25 message(WARNING "Can't build compiler-rt, CMake 2.8.8 required!")
26 endif()
22 add_llvm_external_project(compiler-rt)
2723 endif()
2824
2925 add_llvm_external_project(dragonegg)